summaryrefslogtreecommitdiffstats
path: root/src/yuzu_cmd/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Oboe <github@oboe.email>2022-12-24 03:39:59 +0100
committerGitHub <noreply@github.com>2022-12-24 03:39:59 +0100
commit201733d1b52a98f58ff4bd81a932c69d5b833a29 (patch)
treefd9de3713e5d091b995e1ba499a605e1041aec97 /src/yuzu_cmd/CMakeLists.txt
parentMerge pull request #9476 from liamwhite/async-shutdown (diff)
downloadyuzu-201733d1b52a98f58ff4bd81a932c69d5b833a29.tar
yuzu-201733d1b52a98f58ff4bd81a932c69d5b833a29.tar.gz
yuzu-201733d1b52a98f58ff4bd81a932c69d5b833a29.tar.bz2
yuzu-201733d1b52a98f58ff4bd81a932c69d5b833a29.tar.lz
yuzu-201733d1b52a98f58ff4bd81a932c69d5b833a29.tar.xz
yuzu-201733d1b52a98f58ff4bd81a932c69d5b833a29.tar.zst
yuzu-201733d1b52a98f58ff4bd81a932c69d5b833a29.zip
Diffstat (limited to 'src/yuzu_cmd/CMakeLists.txt')
-rw-r--r--src/yuzu_cmd/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/src/yuzu_cmd/CMakeLists.txt b/src/yuzu_cmd/CMakeLists.txt
index f6eeb9d8d..61b6cc4e0 100644
--- a/src/yuzu_cmd/CMakeLists.txt
+++ b/src/yuzu_cmd/CMakeLists.txt
@@ -49,6 +49,15 @@ if(UNIX AND NOT APPLE)
install(TARGETS yuzu-cmd)
endif()
+if(WIN32)
+ # compile as a win32 gui application instead of a console application
+ if(MSVC)
+ set_target_properties(yuzu-cmd PROPERTIES LINK_FLAGS_RELEASE "/SUBSYSTEM:WINDOWS /ENTRY:mainCRTStartup")
+ elseif(MINGW)
+ set_target_properties(yuzu-cmd PROPERTIES LINK_FLAGS_RELEASE "-Wl,--subsystem,windows")
+ endif()
+endif()
+
if (MSVC)
include(CopyYuzuSDLDeps)
copy_yuzu_SDL_deps(yuzu-cmd)