summaryrefslogtreecommitdiffstats
path: root/src/yuzu_cmd/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2022-12-04 16:44:12 +0100
committerGitHub <noreply@github.com>2022-12-04 16:44:12 +0100
commit02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4 (patch)
tree25de4a77ee6f3f29e01470bf885b4fa58deb8323 /src/yuzu_cmd/CMakeLists.txt
parentMerge pull request #9344 from liamwhite/null (diff)
parentexternals: update dynarmic, SDL2 (diff)
downloadyuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.gz
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.bz2
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.lz
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.xz
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.zst
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.zip
Diffstat (limited to 'src/yuzu_cmd/CMakeLists.txt')
-rw-r--r--src/yuzu_cmd/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/yuzu_cmd/CMakeLists.txt b/src/yuzu_cmd/CMakeLists.txt
index 13b673186..607b4e6aa 100644
--- a/src/yuzu_cmd/CMakeLists.txt
+++ b/src/yuzu_cmd/CMakeLists.txt
@@ -46,8 +46,9 @@ target_include_directories(yuzu-cmd PRIVATE ${RESOURCES_DIR})
target_include_directories(yuzu-cmd PRIVATE ../../externals/Vulkan-Headers/include)
if (YUZU_USE_EXTERNAL_SDL2)
- target_compile_definitions(yuzu-cmd PRIVATE -DYUZU_USE_EXTERNAL_SDL2)
- target_include_directories(yuzu-cmd PRIVATE ${PROJECT_BINARY_DIR}/externals/SDL/include)
+ target_link_libraries(yuzu-cmd PRIVATE SDL2-static)
+else()
+ target_link_libraries(yuzu-cmd PRIVATE SDL2)
endif()
if(UNIX AND NOT APPLE)