summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorLC <mathew1800@gmail.com>2020-10-28 08:14:58 +0100
committerGitHub <noreply@github.com>2020-10-28 08:14:58 +0100
commit55ac6f7a2bf2d2a777f8198806383a093e698453 (patch)
treeefebd3b7a220d23859c96e41e365763e92d74632 /src/video_core/CMakeLists.txt
parentMerge pull request #4842 from liushuyu/fix-web-srv (diff)
parentvideo_core: Enforce -Wredundant-move and -Wpessimizing-move (diff)
downloadyuzu-55ac6f7a2bf2d2a777f8198806383a093e698453.tar
yuzu-55ac6f7a2bf2d2a777f8198806383a093e698453.tar.gz
yuzu-55ac6f7a2bf2d2a777f8198806383a093e698453.tar.bz2
yuzu-55ac6f7a2bf2d2a777f8198806383a093e698453.tar.lz
yuzu-55ac6f7a2bf2d2a777f8198806383a093e698453.tar.xz
yuzu-55ac6f7a2bf2d2a777f8198806383a093e698453.tar.zst
yuzu-55ac6f7a2bf2d2a777f8198806383a093e698453.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index fdfc885fc..567084241 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -302,6 +302,8 @@ else()
target_compile_options(video_core PRIVATE
-Werror=conversion
-Wno-error=sign-conversion
+ -Werror=pessimizing-move
+ -Werror=redundant-move
-Werror=switch
-Werror=unused-variable