summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorAmeer J <52414509+ameerj@users.noreply.github.com>2021-02-09 03:13:10 +0100
committerGitHub <noreply@github.com>2021-02-09 03:13:10 +0100
commit26669d9e134d2f5ce0ff75b23af5719b6521c68b (patch)
tree94fd14bc2646bb1215006483999970cb04d2a7e3 /src/video_core/CMakeLists.txt
parentMerge pull request #5892 from german77/backup (diff)
parentffmpeg: Checkout tag n4.3.1 (diff)
downloadyuzu-26669d9e134d2f5ce0ff75b23af5719b6521c68b.tar
yuzu-26669d9e134d2f5ce0ff75b23af5719b6521c68b.tar.gz
yuzu-26669d9e134d2f5ce0ff75b23af5719b6521c68b.tar.bz2
yuzu-26669d9e134d2f5ce0ff75b23af5719b6521c68b.tar.lz
yuzu-26669d9e134d2f5ce0ff75b23af5719b6521c68b.tar.xz
yuzu-26669d9e134d2f5ce0ff75b23af5719b6521c68b.tar.zst
yuzu-26669d9e134d2f5ce0ff75b23af5719b6521c68b.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 2cf95937e..dd4c29ed3 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -271,14 +271,13 @@ create_target_directory_groups(video_core)
target_link_libraries(video_core PUBLIC common core)
target_link_libraries(video_core PRIVATE glad xbyak)
-if (MSVC)
- target_include_directories(video_core PRIVATE ${FFMPEG_INCLUDE_DIR})
- target_link_libraries(video_core PUBLIC ${FFMPEG_LIBRARY_DIR}/swscale.lib ${FFMPEG_LIBRARY_DIR}/avcodec.lib ${FFMPEG_LIBRARY_DIR}/avutil.lib)
-else()
- target_include_directories(video_core PRIVATE ${FFMPEG_INCLUDE_DIR})
- target_link_libraries(video_core PRIVATE ${FFMPEG_LIBRARIES})
+if (YUZU_USE_BUNDLED_FFMPEG AND NOT WIN32)
+ add_dependencies(video_core ffmpeg-build)
endif()
+target_include_directories(video_core PRIVATE ${FFmpeg_INCLUDE_DIR})
+target_link_libraries(video_core PRIVATE ${FFmpeg_LIBRARIES})
+
add_dependencies(video_core host_shaders)
target_include_directories(video_core PRIVATE ${HOST_SHADERS_INCLUDE})
target_include_directories(video_core PRIVATE sirit ../../externals/Vulkan-Headers/include)