summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2020-09-17 05:43:23 +0200
committerGitHub <noreply@github.com>2020-09-17 05:43:23 +0200
commit1eae35621e74dc85cfbbab38b56f228bf7e38bf0 (patch)
tree7d9025464cca40265141fb3f39ef7b2ef76c5234 /src/video_core/CMakeLists.txt
parentMerge pull request #4662 from lioncash/factory (diff)
parentvideo_core: Enforce -Werror=switch (diff)
downloadyuzu-1eae35621e74dc85cfbbab38b56f228bf7e38bf0.tar
yuzu-1eae35621e74dc85cfbbab38b56f228bf7e38bf0.tar.gz
yuzu-1eae35621e74dc85cfbbab38b56f228bf7e38bf0.tar.bz2
yuzu-1eae35621e74dc85cfbbab38b56f228bf7e38bf0.tar.lz
yuzu-1eae35621e74dc85cfbbab38b56f228bf7e38bf0.tar.xz
yuzu-1eae35621e74dc85cfbbab38b56f228bf7e38bf0.tar.zst
yuzu-1eae35621e74dc85cfbbab38b56f228bf7e38bf0.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index d85f1e9d1..f52b55ef3 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -269,5 +269,5 @@ endif()
if (MSVC)
target_compile_options(video_core PRIVATE /we4267)
else()
- target_compile_options(video_core PRIVATE -Werror=conversion -Wno-error=sign-conversion)
+ target_compile_options(video_core PRIVATE -Werror=conversion -Wno-error=sign-conversion -Werror=switch)
endif()