summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorFernando Sahmkow <fsahmkow27@gmail.com>2019-09-23 20:02:02 +0200
committerFernandoS27 <fsahmkow27@gmail.com>2019-10-25 15:01:29 +0200
commit1a58f45d76fe7756dd365e099d1536da769c1eab (patch)
tree668a61e870c57249edf94ba2e2002d3ace18b118 /src/video_core/CMakeLists.txt
parentShader_IR: Implement BRX tracking. (diff)
downloadyuzu-1a58f45d76fe7756dd365e099d1536da769c1eab.tar
yuzu-1a58f45d76fe7756dd365e099d1536da769c1eab.tar.gz
yuzu-1a58f45d76fe7756dd365e099d1536da769c1eab.tar.bz2
yuzu-1a58f45d76fe7756dd365e099d1536da769c1eab.tar.lz
yuzu-1a58f45d76fe7756dd365e099d1536da769c1eab.tar.xz
yuzu-1a58f45d76fe7756dd365e099d1536da769c1eab.tar.zst
yuzu-1a58f45d76fe7756dd365e099d1536da769c1eab.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index eaa694ff8..cb6eda1b8 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -6,6 +6,7 @@ add_library(video_core STATIC
dma_pusher.h
debug_utils/debug_utils.cpp
debug_utils/debug_utils.h
+ engines/const_buffer_engine_interface.h
engines/const_buffer_info.h
engines/engine_upload.cpp
engines/engine_upload.h
@@ -107,10 +108,12 @@ add_library(video_core STATIC
shader/decode/other.cpp
shader/ast.cpp
shader/ast.h
- shader/control_flow.cpp
- shader/control_flow.h
shader/compiler_settings.cpp
shader/compiler_settings.h
+ shader/const_buffer_locker.cpp
+ shader/const_buffer_locker.h
+ shader/control_flow.cpp
+ shader/control_flow.h
shader/decode.cpp
shader/expr.cpp
shader/expr.h