summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorMai <mathew1800@gmail.com>2022-06-15 03:08:58 +0200
committerGitHub <noreply@github.com>2022-06-15 03:08:58 +0200
commit103997ee56ebec3f417e93ed42e3047d8005125b (patch)
tree18b81c112665f830371408599ae157fc83936a70 /src/video_core/CMakeLists.txt
parentMerge pull request #8462 from liamwhite/dynarmic-profile (diff)
parentexternals: Update cpp-httplib to latest (diff)
downloadyuzu-103997ee56ebec3f417e93ed42e3047d8005125b.tar
yuzu-103997ee56ebec3f417e93ed42e3047d8005125b.tar.gz
yuzu-103997ee56ebec3f417e93ed42e3047d8005125b.tar.bz2
yuzu-103997ee56ebec3f417e93ed42e3047d8005125b.tar.lz
yuzu-103997ee56ebec3f417e93ed42e3047d8005125b.tar.xz
yuzu-103997ee56ebec3f417e93ed42e3047d8005125b.tar.zst
yuzu-103997ee56ebec3f417e93ed42e3047d8005125b.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 256695804..14de7bc89 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -258,10 +258,6 @@ if (MSVC)
target_compile_options(video_core PRIVATE
/we4242 # 'identifier': conversion from 'type1' to 'type2', possible loss of data
/we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
- /we4456 # Declaration of 'identifier' hides previous local declaration
- /we4457 # Declaration of 'identifier' hides function parameter
- /we4458 # Declaration of 'identifier' hides class member
- /we4459 # Declaration of 'identifier' hides global declaration
)
else()
target_compile_options(video_core PRIVATE
@@ -269,7 +265,6 @@ else()
-Wno-error=sign-conversion
-Werror=pessimizing-move
-Werror=redundant-move
- -Werror=shadow
-Werror=type-limits
$<$<CXX_COMPILER_ID:GNU>:-Werror=class-memaccess>