summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorRodrigo Locatti <reinuseslisp@airmail.cc>2020-12-25 07:11:47 +0100
committerGitHub <noreply@github.com>2020-12-25 07:11:47 +0100
commit0dc4ab42cc1efba566d428c84221a82ef5c76283 (patch)
tree10496fe2792e167f325c926a6204f021452dd228 /src/video_core/CMakeLists.txt
parentMerge pull request #5225 from ReinUsesLisp/always-vulkan (diff)
parentvideo_core: Enforce C4715 (not all control paths return a value) (diff)
downloadyuzu-0dc4ab42cc1efba566d428c84221a82ef5c76283.tar
yuzu-0dc4ab42cc1efba566d428c84221a82ef5c76283.tar.gz
yuzu-0dc4ab42cc1efba566d428c84221a82ef5c76283.tar.bz2
yuzu-0dc4ab42cc1efba566d428c84221a82ef5c76283.tar.lz
yuzu-0dc4ab42cc1efba566d428c84221a82ef5c76283.tar.xz
yuzu-0dc4ab42cc1efba566d428c84221a82ef5c76283.tar.zst
yuzu-0dc4ab42cc1efba566d428c84221a82ef5c76283.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 26db24d0f..5b73724ce 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -294,6 +294,7 @@ if (MSVC)
/we4457 # Declaration of 'identifier' hides function parameter
/we4458 # Declaration of 'identifier' hides class member
/we4459 # Declaration of 'identifier' hides global declaration
+ /we4715 # 'function' : not all control paths return a value
)
else()
target_compile_options(video_core PRIVATE