summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2022-12-04 16:44:12 +0100
committerGitHub <noreply@github.com>2022-12-04 16:44:12 +0100
commit02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4 (patch)
tree25de4a77ee6f3f29e01470bf885b4fa58deb8323 /src/video_core/CMakeLists.txt
parentMerge pull request #9344 from liamwhite/null (diff)
parentexternals: update dynarmic, SDL2 (diff)
downloadyuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.gz
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.bz2
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.lz
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.xz
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.tar.zst
yuzu-02b10a6e4dca0ed94e20e1b7dcc69a073d1f22a4.zip
Diffstat (limited to 'src/video_core/CMakeLists.txt')
-rw-r--r--src/video_core/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 6ecc8dbff..b9bad63ac 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -284,9 +284,15 @@ if (MSVC)
/we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
)
else()
- target_compile_options(video_core PRIVATE
- -Werror=conversion
+ if (APPLE)
+ # error: declaration shadows a typedef in 'interval_base_set<SubType, DomainT, Compare, Interval, Alloc>'
+ # error: implicit conversion loses integer precision: 'int' to 'boost::icl::bound_type' (aka 'unsigned char')
+ target_compile_options(video_core PRIVATE -Wno-shadow -Wno-unused-local-typedef)
+ else()
+ target_compile_options(video_core PRIVATE -Werror=conversion)
+ endif()
+ target_compile_options(video_core PRIVATE
-Wno-sign-conversion
)