summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2024-02-18 04:22:06 +0100
committerGitHub <noreply@github.com>2024-02-18 04:22:06 +0100
commite7146309dec4fab504977186571228571efed009 (patch)
treeb1302cb237f91c5f0ccb9863a0b0a2fb427a3c14 /src/input_common/CMakeLists.txt
parentMerge pull request #13017 from liamwhite/suspension (diff)
parentandroid: Input mapping (diff)
downloadyuzu-e7146309dec4fab504977186571228571efed009.tar
yuzu-e7146309dec4fab504977186571228571efed009.tar.gz
yuzu-e7146309dec4fab504977186571228571efed009.tar.bz2
yuzu-e7146309dec4fab504977186571228571efed009.tar.lz
yuzu-e7146309dec4fab504977186571228571efed009.tar.xz
yuzu-e7146309dec4fab504977186571228571efed009.tar.zst
yuzu-e7146309dec4fab504977186571228571efed009.zip
Diffstat (limited to 'src/input_common/CMakeLists.txt')
-rw-r--r--src/input_common/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index d0a71a15b..d455323e0 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -2,8 +2,6 @@
# SPDX-License-Identifier: GPL-2.0-or-later
add_library(input_common STATIC
- drivers/android.cpp
- drivers/android.h
drivers/camera.cpp
drivers/camera.h
drivers/keyboard.cpp
@@ -94,3 +92,11 @@ target_link_libraries(input_common PUBLIC hid_core PRIVATE common Boost::headers
if (YUZU_USE_PRECOMPILED_HEADERS)
target_precompile_headers(input_common PRIVATE precompiled_headers.h)
endif()
+
+if (ANDROID)
+ target_sources(input_common PRIVATE
+ drivers/android.cpp
+ drivers/android.h
+ )
+ target_link_libraries(input_common PRIVATE android)
+endif()