summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-09-12 15:17:50 +0200
committerGitHub <noreply@github.com>2023-09-12 15:17:50 +0200
commitce5320c49f6e3c1dc52b9046213366dd0df1612f (patch)
tree58d116258d42771a5ccda31775b127113b1ea256 /src/common/CMakeLists.txt
parentci: fix msvc when used with LTO (#11459) (diff)
parentadd a compile time option to allow disabling portable mode (diff)
downloadyuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.gz
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.bz2
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.lz
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.xz
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.tar.zst
yuzu-ce5320c49f6e3c1dc52b9046213366dd0df1612f.zip
Diffstat (limited to 'src/common/CMakeLists.txt')
-rw-r--r--src/common/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 6d2badf76..34877b461 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -151,6 +151,10 @@ add_library(common STATIC
zstd_compression.h
)
+if (YUZU_ENABLE_PORTABLE)
+ add_compile_definitions(YUZU_ENABLE_PORTABLE)
+endif()
+
if (WIN32)
target_sources(common PRIVATE
windows/timer_resolution.cpp