summaryrefslogtreecommitdiffstats
path: root/src/citra/CMakeLists.txt
diff options
context:
space:
mode:
authorMerryMage <MerryMage@users.noreply.github.com>2016-03-01 18:24:18 +0100
committerMerryMage <MerryMage@users.noreply.github.com>2016-03-02 15:09:02 +0100
commitba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab (patch)
tree182d660b2f2c8572266144f46817e5a221aa4caf /src/citra/CMakeLists.txt
parentMerge pull request #1424 from MerryMage/lut_init (diff)
downloadyuzu-ba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab.tar
yuzu-ba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab.tar.gz
yuzu-ba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab.tar.bz2
yuzu-ba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab.tar.lz
yuzu-ba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab.tar.xz
yuzu-ba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab.tar.zst
yuzu-ba2a54a9dd6e5a263c5e6886e55b3bc55b95b4ab.zip
Diffstat (limited to 'src/citra/CMakeLists.txt')
-rw-r--r--src/citra/CMakeLists.txt19
1 files changed, 14 insertions, 5 deletions
diff --git a/src/citra/CMakeLists.txt b/src/citra/CMakeLists.txt
index b9abb818e..fa615deb9 100644
--- a/src/citra/CMakeLists.txt
+++ b/src/citra/CMakeLists.txt
@@ -1,11 +1,11 @@
set(SRCS
- emu_window/emu_window_glfw.cpp
+ emu_window/emu_window_sdl2.cpp
citra.cpp
config.cpp
citra.rc
)
set(HEADERS
- emu_window/emu_window_glfw.h
+ emu_window/emu_window_sdl2.h
config.h
default_ini.h
resource.h
@@ -13,12 +13,11 @@ set(HEADERS
create_directory_groups(${SRCS} ${HEADERS})
-include_directories(${GLFW_INCLUDE_DIRS})
-link_directories(${GLFW_LIBRARY_DIRS})
+include_directories(${SDL2_INCLUDE_DIR})
add_executable(citra ${SRCS} ${HEADERS})
target_link_libraries(citra core video_core audio_core common)
-target_link_libraries(citra ${GLFW_LIBRARIES} ${OPENGL_gl_LIBRARY} inih glad)
+target_link_libraries(citra ${SDL2_LIBRARY} ${OPENGL_gl_LIBRARY} inih glad)
if (MSVC)
target_link_libraries(citra getopt)
endif()
@@ -27,3 +26,13 @@ target_link_libraries(citra ${PLATFORM_LIBRARIES})
if(${CMAKE_SYSTEM_NAME} MATCHES "Linux|FreeBSD|OpenBSD|NetBSD")
install(TARGETS citra RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
endif()
+
+if (MSVC)
+ include(WindowsCopyFiles)
+
+ set(DLL_DEST "${CMAKE_BINARY_DIR}/bin/$<CONFIG>/")
+
+ windows_copy_files(citra ${SDL2_DLL_DIR} ${DLL_DEST} SDL2.dll)
+
+ unset(DLL_DEST)
+endif()