summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2020-10-14 00:30:30 +0200
committerGitHub <noreply@github.com>2020-10-14 00:30:30 +0200
commitca416a0fb87ced0e471729fe344b9f34a090e7b5 (patch)
treed1a143eb839744bc1515700c861ec7e5d04d130e /src/audio_core/CMakeLists.txt
parentMerge pull request #4786 from lioncash/flags (diff)
parentaudio_core/CMakeLists: Make warnings consistent with core (diff)
downloadyuzu-ca416a0fb87ced0e471729fe344b9f34a090e7b5.tar
yuzu-ca416a0fb87ced0e471729fe344b9f34a090e7b5.tar.gz
yuzu-ca416a0fb87ced0e471729fe344b9f34a090e7b5.tar.bz2
yuzu-ca416a0fb87ced0e471729fe344b9f34a090e7b5.tar.lz
yuzu-ca416a0fb87ced0e471729fe344b9f34a090e7b5.tar.xz
yuzu-ca416a0fb87ced0e471729fe344b9f34a090e7b5.tar.zst
yuzu-ca416a0fb87ced0e471729fe344b9f34a090e7b5.zip
Diffstat (limited to 'src/audio_core/CMakeLists.txt')
-rw-r--r--src/audio_core/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index 6a7075f73..54940a034 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -46,10 +46,13 @@ create_target_directory_groups(audio_core)
if (NOT MSVC)
target_compile_options(audio_core PRIVATE
+ -Werror=conversion
-Werror=ignored-qualifiers
-Werror=implicit-fallthrough
-Werror=reorder
-Werror=sign-compare
+ -Werror=unused-but-set-parameter
+ -Werror=unused-but-set-variable
-Werror=unused-variable
)
endif()