summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2020-09-27 10:52:59 +0200
committerGitHub <noreply@github.com>2020-09-27 10:52:59 +0200
commita8be822e8eb5cda83b09bcf6c1478b8bef2f2caf (patch)
tree2ffdcbce07231caba437d6ac1cbfe23f3a02f16e /src/audio_core/CMakeLists.txt
parentMerge pull request #4724 from lat9nq/fix-vulkan-nvidia-allocate-2 (diff)
parentaudio_core: Resolve sign conversion warnings (diff)
downloadyuzu-a8be822e8eb5cda83b09bcf6c1478b8bef2f2caf.tar
yuzu-a8be822e8eb5cda83b09bcf6c1478b8bef2f2caf.tar.gz
yuzu-a8be822e8eb5cda83b09bcf6c1478b8bef2f2caf.tar.bz2
yuzu-a8be822e8eb5cda83b09bcf6c1478b8bef2f2caf.tar.lz
yuzu-a8be822e8eb5cda83b09bcf6c1478b8bef2f2caf.tar.xz
yuzu-a8be822e8eb5cda83b09bcf6c1478b8bef2f2caf.tar.zst
yuzu-a8be822e8eb5cda83b09bcf6c1478b8bef2f2caf.zip
Diffstat (limited to 'src/audio_core/CMakeLists.txt')
-rw-r--r--src/audio_core/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index cb00ef60e..6a7075f73 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -44,6 +44,16 @@ add_library(audio_core STATIC
create_target_directory_groups(audio_core)
+if (NOT MSVC)
+ target_compile_options(audio_core PRIVATE
+ -Werror=ignored-qualifiers
+ -Werror=implicit-fallthrough
+ -Werror=reorder
+ -Werror=sign-compare
+ -Werror=unused-variable
+ )
+endif()
+
target_link_libraries(audio_core PUBLIC common core)
target_link_libraries(audio_core PRIVATE SoundTouch)