summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2022-10-21 08:34:06 +0200
committerMorph <39850852+Morph1984@users.noreply.github.com>2022-10-22 21:02:04 +0200
commit93297d14d8fc5c8f73e8ccba5ca989590a453c05 (patch)
tree4b25f5ceda595051501136a7f3000e7ef989e1f1 /src/audio_core/CMakeLists.txt
parentCMakeLists: Consolidate all unused warnings into -Wunused (diff)
downloadyuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.gz
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.bz2
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.lz
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.xz
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.tar.zst
yuzu-93297d14d8fc5c8f73e8ccba5ca989590a453c05.zip
Diffstat (limited to 'src/audio_core/CMakeLists.txt')
-rw-r--r--src/audio_core/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index 144f1bab2..01b4ffd88 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -206,20 +206,10 @@ if (MSVC)
/we4244 # 'conversion': conversion from 'type1' to 'type2', possible loss of data
/we4245 # 'conversion': conversion from 'type1' to 'type2', signed/unsigned mismatch
/we4254 # 'operator': conversion from 'type1:field_bits' to 'type2:field_bits', possible loss of data
- /we4456 # Declaration of 'identifier' hides previous local declaration
- /we4457 # Declaration of 'identifier' hides function parameter
- /we4458 # Declaration of 'identifier' hides class member
- /we4459 # Declaration of 'identifier' hides global declaration
)
else()
target_compile_options(audio_core PRIVATE
-Werror=conversion
- -Werror=ignored-qualifiers
- -Werror=shadow
- -Werror=unused-variable
-
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>
- $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>
-Wno-sign-conversion
)