summaryrefslogtreecommitdiffstats
path: root/src/audio_core/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2020-12-03 08:08:43 +0100
committerGitHub <noreply@github.com>2020-12-03 08:08:43 +0100
commit88089c87546b62536a27738f5ee03dff52fa76e9 (patch)
tree5221c80d0ac3e7bbdb0c342098378e6c84951658 /src/audio_core/CMakeLists.txt
parentMerge pull request #5002 from ameerj/nvdec-frameskip (diff)
parentaudio_core: Make shadowing and unused parameters errors (diff)
downloadyuzu-88089c87546b62536a27738f5ee03dff52fa76e9.tar
yuzu-88089c87546b62536a27738f5ee03dff52fa76e9.tar.gz
yuzu-88089c87546b62536a27738f5ee03dff52fa76e9.tar.bz2
yuzu-88089c87546b62536a27738f5ee03dff52fa76e9.tar.lz
yuzu-88089c87546b62536a27738f5ee03dff52fa76e9.tar.xz
yuzu-88089c87546b62536a27738f5ee03dff52fa76e9.tar.zst
yuzu-88089c87546b62536a27738f5ee03dff52fa76e9.zip
Diffstat (limited to 'src/audio_core/CMakeLists.txt')
-rw-r--r--src/audio_core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/audio_core/CMakeLists.txt b/src/audio_core/CMakeLists.txt
index 68c67507b..d1d177b51 100644
--- a/src/audio_core/CMakeLists.txt
+++ b/src/audio_core/CMakeLists.txt
@@ -51,6 +51,8 @@ if (NOT MSVC)
-Werror=implicit-fallthrough
-Werror=reorder
-Werror=sign-compare
+ -Werror=shadow
+ -Werror=unused-parameter
-Werror=unused-variable
$<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>