summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMat M <mathew1800@gmail.com>2019-05-14 12:34:53 +0200
committerGitHub <noreply@github.com>2019-05-14 12:34:53 +0200
commit8b933e77cd385abe69298dfca6acabd13888aa0a (patch)
tree14491db59a25529143e9126f63ea6db51e80537f /src/CMakeLists.txt
parentMerge pull request #2450 from lioncash/warn-level (diff)
parentCMakeLists: Specify /volatile:iso for MSVC (diff)
downloadyuzu-8b933e77cd385abe69298dfca6acabd13888aa0a.tar
yuzu-8b933e77cd385abe69298dfca6acabd13888aa0a.tar.gz
yuzu-8b933e77cd385abe69298dfca6acabd13888aa0a.tar.bz2
yuzu-8b933e77cd385abe69298dfca6acabd13888aa0a.tar.lz
yuzu-8b933e77cd385abe69298dfca6acabd13888aa0a.tar.xz
yuzu-8b933e77cd385abe69298dfca6acabd13888aa0a.tar.zst
yuzu-8b933e77cd385abe69298dfca6acabd13888aa0a.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 3f781a547..04018233f 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -27,6 +27,7 @@ if (MSVC)
# /Zo - Enhanced debug info for optimized builds
# /permissive- - Enables stricter C++ standards conformance checks
# /EHsc - C++-only exception handling semantics
+ # /volatile:iso - Use strict standards-compliant volatile semantics.
# /Zc:externConstexpr - Allow extern constexpr variables to have external linkage, like the standard mandates
# /Zc:inline - Let codegen omit inline functions in object files
# /Zc:throwingNew - Let codegen assume `operator new` (without std::nothrow) will never return null
@@ -38,6 +39,7 @@ if (MSVC)
/permissive-
/EHsc
/std:c++latest
+ /volatile:iso
/Zc:externConstexpr
/Zc:inline
/Zc:throwingNew