summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRodrigo Locatti <reinuseslisp@airmail.cc>2021-01-09 07:13:25 +0100
committerGitHub <noreply@github.com>2021-01-09 07:13:25 +0100
commit7bad1974a6bc2fba9f47824d4da23e888f6ff4a7 (patch)
tree77b7fe5542e1d5cc2d92ad3ea7410c6b95eca449 /src/CMakeLists.txt
parentMerge pull request #5231 from ReinUsesLisp/dyn-bindings (diff)
parentcmake: Enforce C4062, C4265, C4388, and C5038 (diff)
downloadyuzu-7bad1974a6bc2fba9f47824d4da23e888f6ff4a7.tar
yuzu-7bad1974a6bc2fba9f47824d4da23e888f6ff4a7.tar.gz
yuzu-7bad1974a6bc2fba9f47824d4da23e888f6ff4a7.tar.bz2
yuzu-7bad1974a6bc2fba9f47824d4da23e888f6ff4a7.tar.lz
yuzu-7bad1974a6bc2fba9f47824d4da23e888f6ff4a7.tar.xz
yuzu-7bad1974a6bc2fba9f47824d4da23e888f6ff4a7.tar.zst
yuzu-7bad1974a6bc2fba9f47824d4da23e888f6ff4a7.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 8777df751..daf251d19 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -45,10 +45,14 @@ if (MSVC)
# Warnings
/W3
+ /we4062 # enumerator 'identifier' in a switch of enum 'enumeration' is not handled
+ /we4265 # 'class': class has virtual functions, but destructor is not virtual
+ /we4388 # signed/unsigned mismatch
/we4547 # 'operator' : operator before comma has no effect; expected operator with side-effect
/we4549 # 'operator1': operator before comma has no effect; did you intend 'operator2'?
/we4555 # Expression has no effect; expected expression with side-effect
/we4834 # Discarding return value of function with 'nodiscard' attribute
+ /we5038 # data member 'member1' will be initialized after data member 'member2'
)
# /GS- - No stack buffer overflow checks