summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorliamwhite <liamwhite@users.noreply.github.com>2023-09-06 15:12:58 +0200
committerGitHub <noreply@github.com>2023-09-06 15:12:58 +0200
commit5e424d791bd98c18a81a36405a419237abcc8116 (patch)
treedd83795955a607612d27f324bdb1bfab63de2c38 /src/CMakeLists.txt
parentMerge pull request #11437 from liamwhite/dump-shenanigans (diff)
parentmsvc: set warning level to /W4 globally (diff)
downloadyuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.gz
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.bz2
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.lz
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.xz
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.tar.zst
yuzu-5e424d791bd98c18a81a36405a419237abcc8116.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index a9f68a8f2..95d54dadc 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -24,7 +24,7 @@ if (MSVC)
# Ensure that projects build with Unicode support.
add_definitions(-DUNICODE -D_UNICODE)
- # /W3 - Level 3 warnings
+ # /W4 - Level 4 warnings
# /MP - Multi-threaded compilation
# /Zi - Output debugging information
# /Zm - Specifies the precompiled header memory allocation limit
@@ -61,7 +61,7 @@ if (MSVC)
/external:W0 # Sets the default warning level to 0 for external headers, effectively turning off warnings for external headers
# Warnings
- /W3
+ /W4
/WX
/we4062 # Enumerator 'identifier' in a switch of enum 'enumeration' is not handled
@@ -84,12 +84,16 @@ if (MSVC)
/wd4100 # 'identifier': unreferenced formal parameter
/wd4324 # 'struct_name': structure was padded due to __declspec(align())
+ /wd4201 # nonstandard extension used : nameless struct/union
)
if (USE_CCACHE OR YUZU_USE_PRECOMPILED_HEADERS)
# when caching, we need to use /Z7 to downgrade debug info to use an older but more cacheable format
# Precompiled headers are deleted if not using /Z7. See https://github.com/nanoant/CMakePCHCompiler/issues/21
add_compile_options(/Z7)
+ # Avoid D9025 warning
+ string(REPLACE "/Zi" "" CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO}")
+ string(REPLACE "/Zi" "" CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG}")
else()
add_compile_options(/Zi)
endif()