summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-10-30 04:30:42 +0100
committerLioncash <mathew1800@gmail.com>2020-10-30 05:13:21 +0100
commit26547d3e3be403047445fd39e671d7ef3b88dabb (patch)
tree2189a7d0f6eb01a30a16ce2137bb952a0a854fea /src/CMakeLists.txt
parentMerge pull request #4831 from lioncash/fmt (diff)
downloadyuzu-26547d3e3be403047445fd39e671d7ef3b88dabb.tar
yuzu-26547d3e3be403047445fd39e671d7ef3b88dabb.tar.gz
yuzu-26547d3e3be403047445fd39e671d7ef3b88dabb.tar.bz2
yuzu-26547d3e3be403047445fd39e671d7ef3b88dabb.tar.lz
yuzu-26547d3e3be403047445fd39e671d7ef3b88dabb.tar.xz
yuzu-26547d3e3be403047445fd39e671d7ef3b88dabb.tar.zst
yuzu-26547d3e3be403047445fd39e671d7ef3b88dabb.zip
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 71efbb40d..29c6ffc67 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -32,7 +32,6 @@ if (MSVC)
# /Zc:inline - Let codegen omit inline functions in object files
# /Zc:throwingNew - Let codegen assume `operator new` (without std::nothrow) will never return null
add_compile_options(
- /W3
/MP
/Zi
/Zo
@@ -43,6 +42,10 @@ if (MSVC)
/Zc:externConstexpr
/Zc:inline
/Zc:throwingNew
+
+ # Warnings
+ /W3
+ /we4834 # Discarding return value of function with 'nodiscard' attribute
)
# /GS- - No stack buffer overflow checks
@@ -56,6 +59,7 @@ else()
-Werror=implicit-fallthrough
-Werror=missing-declarations
-Werror=reorder
+ -Werror=unused-result
-Wextra
-Wmissing-declarations
-Wno-attributes