summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Rowe <jroweboy@gmail.com>2018-01-12 03:21:20 +0100
committerJames Rowe <jroweboy@gmail.com>2018-01-13 03:11:03 +0100
commitebf9a784a9f7f4148a669dbb39e7cd50df779a14 (patch)
treed585685a1c0a34b903af1d086d62560bf56bb29f /externals/CMakeLists.txt
parentconfig: Default CPU core to Unicorn. (diff)
downloadyuzu-ebf9a784a9f7f4148a669dbb39e7cd50df779a14.tar
yuzu-ebf9a784a9f7f4148a669dbb39e7cd50df779a14.tar.gz
yuzu-ebf9a784a9f7f4148a669dbb39e7cd50df779a14.tar.bz2
yuzu-ebf9a784a9f7f4148a669dbb39e7cd50df779a14.tar.lz
yuzu-ebf9a784a9f7f4148a669dbb39e7cd50df779a14.tar.xz
yuzu-ebf9a784a9f7f4148a669dbb39e7cd50df779a14.tar.zst
yuzu-ebf9a784a9f7f4148a669dbb39e7cd50df779a14.zip
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index 347641c10..ec3c70779 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -38,15 +38,6 @@ target_include_directories(lz4_static INTERFACE ./lz4/lib)
add_library(microprofile INTERFACE)
target_include_directories(microprofile INTERFACE ./microprofile)
-# Nihstro
-add_library(nihstro-headers INTERFACE)
-target_include_directories(nihstro-headers INTERFACE ./nihstro/include)
-
-# SoundTouch
-add_subdirectory(soundtouch)
-# The SoundTouch target doesn't export the necessary include paths as properties by default
-target_include_directories(SoundTouch INTERFACE ./soundtouch/include)
-
# Unicorn
add_library(unicorn-headers INTERFACE)
target_include_directories(unicorn-headers INTERFACE ./unicorn/include)
@@ -58,31 +49,3 @@ if (ARCHITECTURE_x86_64)
target_include_directories(xbyak INTERFACE ./xbyak/xbyak)
target_compile_definitions(xbyak INTERFACE XBYAK_NO_OP_NAMES)
endif()
-
-# ENet
-add_subdirectory(enet)
-target_include_directories(enet INTERFACE ./enet/include)
-
-if (ENABLE_WEB_SERVICE)
- # msys installed curl is configured to use openssl, but that isn't portable
- # since it relies on having the bundled certs install in the home folder for SSL
- # by default on mingw, download the precompiled curl thats linked against windows native ssl
- if (MINGW AND CITRA_USE_BUNDLED_CURL)
- download_bundled_external("curl/" "curl-7_55_1" CURL_PREFIX)
- set(CURL_PREFIX "${CMAKE_BINARY_DIR}/externals/curl-7_55_1")
- set(CURL_FOUND YES)
- set(CURL_INCLUDE_DIR "${CURL_PREFIX}/include" CACHE PATH "Path to curl headers")
- set(CURL_LIBRARY "${CURL_PREFIX}/lib/libcurldll.a" CACHE PATH "Path to curl library")
- set(CURL_DLL_DIR "${CURL_PREFIX}/lib/" CACHE PATH "Path to curl.dll")
- set(USE_SYSTEM_CURL ON CACHE BOOL "")
- endif()
- # CPR
- set(BUILD_TESTING OFF CACHE BOOL "")
- set(BUILD_CPR_TESTS OFF CACHE BOOL "")
- add_subdirectory(cpr)
- target_include_directories(cpr INTERFACE ./cpr/include)
-
- # JSON
- add_library(json-headers INTERFACE)
- target_include_directories(json-headers INTERFACE ./json)
-endif()