summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorlat9nq <22451773+lat9nq@users.noreply.github.com>2021-06-03 09:49:35 +0200
committerlat9nq <22451773+lat9nq@users.noreply.github.com>2021-06-03 09:49:35 +0200
commitddc47e6df8cd9e06d799933f67e75ba6f8952acd (patch)
treef1fd486d62f031cc4606c42dab2fea60d3af5fd2 /externals/CMakeLists.txt
parentcmake: Use autotools to build libusb generally for GNU (diff)
downloadyuzu-ddc47e6df8cd9e06d799933f67e75ba6f8952acd.tar
yuzu-ddc47e6df8cd9e06d799933f67e75ba6f8952acd.tar.gz
yuzu-ddc47e6df8cd9e06d799933f67e75ba6f8952acd.tar.bz2
yuzu-ddc47e6df8cd9e06d799933f67e75ba6f8952acd.tar.lz
yuzu-ddc47e6df8cd9e06d799933f67e75ba6f8952acd.tar.xz
yuzu-ddc47e6df8cd9e06d799933f67e75ba6f8952acd.tar.zst
yuzu-ddc47e6df8cd9e06d799933f67e75ba6f8952acd.zip
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index aae0baa0b..5402a532f 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -45,6 +45,11 @@ target_include_directories(microprofile INTERFACE ./microprofile)
add_library(unicorn-headers INTERFACE)
target_include_directories(unicorn-headers INTERFACE ./unicorn/include)
+# libusb
+if (NOT LIBUSB_FOUND OR YUZU_USE_BUNDLED_LIBUSB)
+ add_subdirectory(libusb)
+endif()
+
# SDL2
if (NOT SDL2_FOUND AND ENABLE_SDL2)
if (NOT WIN32)