summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorbunnei <bunneidev@gmail.com>2017-09-24 17:04:55 +0200
committerbunnei <bunneidev@gmail.com>2017-09-30 20:30:04 +0200
commit9eb4888df7fc7e02e364622878f332fc103ca919 (patch)
tree07ee94850124402f0feaa06870ec8cf77da9ef1e /externals/CMakeLists.txt
parentmemory: Log with 64-bit values. (diff)
downloadyuzu-9eb4888df7fc7e02e364622878f332fc103ca919.tar
yuzu-9eb4888df7fc7e02e364622878f332fc103ca919.tar.gz
yuzu-9eb4888df7fc7e02e364622878f332fc103ca919.tar.bz2
yuzu-9eb4888df7fc7e02e364622878f332fc103ca919.tar.lz
yuzu-9eb4888df7fc7e02e364622878f332fc103ca919.tar.xz
yuzu-9eb4888df7fc7e02e364622878f332fc103ca919.tar.zst
yuzu-9eb4888df7fc7e02e364622878f332fc103ca919.zip
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index 8e4bcf21f..b809d76d8 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -28,6 +28,11 @@ add_subdirectory(glad)
# inih
add_subdirectory(inih)
+# lz4
+set(LZ4_BUNDLED_MODE ON)
+add_subdirectory(lz4/contrib/cmake_unofficial)
+target_include_directories(lz4_static INTERFACE ./lz4/lib)
+
# MicroProfile
add_library(microprofile INTERFACE)
target_include_directories(microprofile INTERFACE ./microprofile)