summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorliushuyu <liushuyu011@gmail.com>2020-10-20 02:14:41 +0200
committerliushuyu <liushuyu011@gmail.com>2020-10-27 09:57:19 +0100
commit8e673cbb08615865044ed546a133259ff2756128 (patch)
tree3aaffed58d535f40440a9da69f1a96451b4c3a7b /externals/CMakeLists.txt
parentMerge pull request #4805 from bunnei/update-defaults (diff)
downloadyuzu-8e673cbb08615865044ed546a133259ff2756128.tar
yuzu-8e673cbb08615865044ed546a133259ff2756128.tar.gz
yuzu-8e673cbb08615865044ed546a133259ff2756128.tar.bz2
yuzu-8e673cbb08615865044ed546a133259ff2756128.tar.lz
yuzu-8e673cbb08615865044ed546a133259ff2756128.tar.xz
yuzu-8e673cbb08615865044ed546a133259ff2756128.tar.zst
yuzu-8e673cbb08615865044ed546a133259ff2756128.zip
Diffstat (limited to 'externals/CMakeLists.txt')
-rw-r--r--externals/CMakeLists.txt25
1 files changed, 14 insertions, 11 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index e01ff6930..b8114f42b 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -73,17 +73,20 @@ if (NOT LIBZIP_FOUND)
endif()
if (ENABLE_WEB_SERVICE)
- # LibreSSL
- set(LIBRESSL_SKIP_INSTALL ON CACHE BOOL "")
- add_subdirectory(libressl EXCLUDE_FROM_ALL)
- target_include_directories(ssl INTERFACE ./libressl/include)
- target_compile_definitions(ssl PRIVATE -DHAVE_INET_NTOP)
- get_directory_property(OPENSSL_LIBRARIES
- DIRECTORY libressl
- DEFINITION OPENSSL_LIBS)
-
- # lurlparser
- add_subdirectory(lurlparser EXCLUDE_FROM_ALL)
+ if (USE_SYSTEM_SSL)
+ find_package(OpenSSL 1.1 REQUIRED)
+ set(OPENSSL_LIBRARIES OpenSSL::SSL OpenSSL::Crypto)
+ else()
+ # LibreSSL
+ set(LIBRESSL_SKIP_INSTALL ON CACHE BOOL "")
+ set(OPENSSLDIR "/etc/ssl/")
+ add_subdirectory(libressl EXCLUDE_FROM_ALL)
+ target_include_directories(ssl INTERFACE ./libressl/include)
+ target_compile_definitions(ssl PRIVATE -DHAVE_INET_NTOP)
+ get_directory_property(OPENSSL_LIBRARIES
+ DIRECTORY libressl
+ DEFINITION OPENSSL_LIBS)
+ endif()
# httplib
add_library(httplib INTERFACE)