summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.com>2023-08-03 10:26:19 +0200
committerDiego Elio Pettenò <flameeyes@flameeyes.com>2023-08-03 10:26:19 +0200
commite4db49c0cf7916a3303eadbdf7fd541e57e1ce9e (patch)
tree2f69f3774cacf41e01bf9afd1518e993063f4cae /pyproject.toml
downloadfreestyle-keys-e4db49c0cf7916a3303eadbdf7fd541e57e1ce9e.tar
freestyle-keys-e4db49c0cf7916a3303eadbdf7fd541e57e1ce9e.tar.gz
freestyle-keys-e4db49c0cf7916a3303eadbdf7fd541e57e1ce9e.tar.bz2
freestyle-keys-e4db49c0cf7916a3303eadbdf7fd541e57e1ce9e.tar.lz
freestyle-keys-e4db49c0cf7916a3303eadbdf7fd541e57e1ce9e.tar.xz
freestyle-keys-e4db49c0cf7916a3303eadbdf7fd541e57e1ce9e.tar.zst
freestyle-keys-e4db49c0cf7916a3303eadbdf7fd541e57e1ce9e.zip
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml52
1 files changed, 52 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..750b6bc
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,52 @@
+# SPDX-FileCopyrightText: 2013 The freestyle-hid Authors
+#
+# SPDX-License-Identifier: 0BSD
+
+# NOTE: you have to use single-quoted strings in TOML for regular expressions.
+# It's the equivalent of r-strings in Python. Multiline strings are treated as
+# verbose regular expressions by Black. Use [ ] to denote a significant space
+# character.
+
+[build-system]
+requires = [
+ 'setuptools >= 42',
+ 'wheel',
+ 'setuptools_scm[toml]>=3.4',
+]
+
+[tool.black]
+line-length = 88
+target-version = ['py37']
+exclude = '''
+/(
+ \.eggs
+ | \.git
+ | \.hg
+ | \.mypy_cache
+ | \.tox
+ | \.venv
+ | _build
+ | buck-out
+ | build
+ | dist
+)/
+'''
+
+[tool.isort]
+# These settings ensure that black and isort don't disagree on the imports.
+line_length = 88
+multi_line_output = 3
+include_trailing_comma = true
+
+[tool.setuptools_scm]
+
+[tool.pytest.ini_options]
+addopts = "--color=yes --ignore=setup.py -ra"
+timeout = 120
+norecursedirs = [
+ '.env',
+ '.git',
+ 'dist',
+ 'build',
+ 'venv',
+]