summaryrefslogtreecommitdiffstats
path: root/src/yuzu_cmd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/yuzu_cmd/CMakeLists.txt')
-rw-r--r--src/yuzu_cmd/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/yuzu_cmd/CMakeLists.txt b/src/yuzu_cmd/CMakeLists.txt
new file mode 100644
index 000000000..c6c527eb6
--- /dev/null
+++ b/src/yuzu_cmd/CMakeLists.txt
@@ -0,0 +1,35 @@
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${PROJECT_SOURCE_DIR}/CMakeModules)
+
+set(SRCS
+ emu_window/emu_window_sdl2.cpp
+ citra.cpp
+ config.cpp
+ citra.rc
+ )
+set(HEADERS
+ emu_window/emu_window_sdl2.h
+ config.h
+ default_ini.h
+ resource.h
+ )
+
+create_directory_groups(${SRCS} ${HEADERS})
+
+add_executable(yuzu-cmd ${SRCS} ${HEADERS})
+target_link_libraries(yuzu-cmd PRIVATE common core input_common)
+target_link_libraries(yuzu-cmd PRIVATE inih glad)
+if (MSVC)
+ target_link_libraries(yuzu-cmd PRIVATE getopt)
+endif()
+target_link_libraries(yuzu-cmd PRIVATE ${PLATFORM_LIBRARIES} SDL2 Threads::Threads)
+
+if(UNIX AND NOT APPLE)
+ install(TARGETS yuzu-cmd RUNTIME DESTINATION "${CMAKE_INSTALL_PREFIX}/bin")
+endif()
+
+if (MSVC)
+ include(CopyCitraSDLDeps)
+ include(CopyYuzuUnicornDeps)
+ copy_citra_SDL_deps(yuzu-cmd)
+ copy_yuzu_unicorn_deps(yuzu-cmd)
+endif()