summaryrefslogtreecommitdiffstats
path: root/externals/gamemode/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'externals/gamemode/CMakeLists.txt')
-rw-r--r--externals/gamemode/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/externals/gamemode/CMakeLists.txt b/externals/gamemode/CMakeLists.txt
new file mode 100644
index 000000000..87095642e
--- /dev/null
+++ b/externals/gamemode/CMakeLists.txt
@@ -0,0 +1,11 @@
+# SPDX-FileCopyrightText: Copyright 2023 yuzu Emulator Project
+# SPDX-License-Identifier: GPL-3.0-or-later
+
+project(gamemode LANGUAGES CXX C)
+
+add_library(gamemode include/gamemode_client.h)
+
+target_link_libraries(gamemode PRIVATE common)
+
+target_include_directories(gamemode PUBLIC include)
+set_target_properties(gamemode PROPERTIES LINKER_LANGUAGE C)