summaryrefslogtreecommitdiffstats
path: root/src/video_core/CMakeLists.txt
diff options
context:
space:
mode:
authorLioncash <mathew1800@gmail.com>2020-10-21 01:24:28 +0200
committerLioncash <mathew1800@gmail.com>2020-10-21 02:28:25 +0200
commit678d012c2c3ce7b6bac136576d15f23b2d4b05a8 (patch)
treea3d71985a6e5456e4efb3cf662460fc29d261cf9 /src/video_core/CMakeLists.txt
parentkernel: Fix build with recent compiler flag changes (diff)
downloadyuzu-678d012c2c3ce7b6bac136576d15f23b2d4b05a8.tar
yuzu-678d012c2c3ce7b6bac136576d15f23b2d4b05a8.tar.gz
yuzu-678d012c2c3ce7b6bac136576d15f23b2d4b05a8.tar.bz2
yuzu-678d012c2c3ce7b6bac136576d15f23b2d4b05a8.tar.lz
yuzu-678d012c2c3ce7b6bac136576d15f23b2d4b05a8.tar.xz
yuzu-678d012c2c3ce7b6bac136576d15f23b2d4b05a8.tar.zst
yuzu-678d012c2c3ce7b6bac136576d15f23b2d4b05a8.zip
Diffstat (limited to '')
-rw-r--r--src/video_core/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/video_core/CMakeLists.txt b/src/video_core/CMakeLists.txt
index 3df54816d..77ebac19f 100644
--- a/src/video_core/CMakeLists.txt
+++ b/src/video_core/CMakeLists.txt
@@ -278,7 +278,9 @@ else()
-Wno-error=sign-conversion
-Werror=switch
-Werror=unused-variable
- -Werror=unused-but-set-variable
- -Werror=class-memaccess
+
+ $<$<CXX_COMPILER_ID:GNU>:-Werror=class-memaccess>
+ $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-parameter>
+ $<$<CXX_COMPILER_ID:GNU>:-Werror=unused-but-set-variable>
)
endif()