summaryrefslogtreecommitdiffstats
path: root/src/input_common/CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Kunde Schlesner <yuriks@yuriks.net>2017-05-28 03:26:55 +0200
committerYuri Kunde Schlesner <yuriks@yuriks.net>2017-05-28 03:41:24 +0200
commit7b81903756451281bd1f07d8e9a2dceeff79df08 (patch)
treeba001a9832ee8965963d17fd4e93e9222e1153de /src/input_common/CMakeLists.txt
parentCitra: Convert include into forward declaration (diff)
downloadyuzu-7b81903756451281bd1f07d8e9a2dceeff79df08.tar
yuzu-7b81903756451281bd1f07d8e9a2dceeff79df08.tar.gz
yuzu-7b81903756451281bd1f07d8e9a2dceeff79df08.tar.bz2
yuzu-7b81903756451281bd1f07d8e9a2dceeff79df08.tar.lz
yuzu-7b81903756451281bd1f07d8e9a2dceeff79df08.tar.xz
yuzu-7b81903756451281bd1f07d8e9a2dceeff79df08.tar.zst
yuzu-7b81903756451281bd1f07d8e9a2dceeff79df08.zip
Diffstat (limited to '')
-rw-r--r--src/input_common/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/input_common/CMakeLists.txt b/src/input_common/CMakeLists.txt
index cfe5caaa3..5b306e42e 100644
--- a/src/input_common/CMakeLists.txt
+++ b/src/input_common/CMakeLists.txt
@@ -19,9 +19,9 @@ endif()
create_directory_groups(${SRCS} ${HEADERS})
add_library(input_common STATIC ${SRCS} ${HEADERS})
-target_link_libraries(input_common common core)
+target_link_libraries(input_common PUBLIC core PRIVATE common)
if(SDL2_FOUND)
- target_link_libraries(input_common ${SDL2_LIBRARY})
- set_property(TARGET input_common APPEND PROPERTY COMPILE_DEFINITIONS HAVE_SDL2)
+ target_link_libraries(input_common PRIVATE ${SDL2_LIBRARY})
+ target_compile_definitions(input_common PRIVATE HAVE_SDL2)
endif()