summaryrefslogtreecommitdiffstats
path: root/src/common/CMakeLists.txt
diff options
context:
space:
mode:
authorReinUsesLisp <reinuseslisp@airmail.cc>2019-02-07 01:55:14 +0100
committerReinUsesLisp <reinuseslisp@airmail.cc>2019-02-07 02:23:41 +0100
commitdfd14618f7cde84caf15f3b56ee14800f2509ebc (patch)
treedddd4ab0851516f67c11d1121e8f233c9f0bafd3 /src/common/CMakeLists.txt
parentgl_shader_disk_cache: Check LZ4 size limit (diff)
downloadyuzu-dfd14618f7cde84caf15f3b56ee14800f2509ebc.tar
yuzu-dfd14618f7cde84caf15f3b56ee14800f2509ebc.tar.gz
yuzu-dfd14618f7cde84caf15f3b56ee14800f2509ebc.tar.bz2
yuzu-dfd14618f7cde84caf15f3b56ee14800f2509ebc.tar.lz
yuzu-dfd14618f7cde84caf15f3b56ee14800f2509ebc.tar.xz
yuzu-dfd14618f7cde84caf15f3b56ee14800f2509ebc.tar.zst
yuzu-dfd14618f7cde84caf15f3b56ee14800f2509ebc.zip
Diffstat (limited to '')
-rw-r--r--src/common/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/common/CMakeLists.txt b/src/common/CMakeLists.txt
index 4b6ddf894..bdd885273 100644
--- a/src/common/CMakeLists.txt
+++ b/src/common/CMakeLists.txt
@@ -3,8 +3,21 @@
# could affect the result, but much more unlikely than the following files. Keeping a list of files
# like this allows for much better caching since it doesn't force the user to recompile binary shaders every update
set(VIDEO_CORE "${CMAKE_SOURCE_DIR}/src/video_core")
+if (DEFINED ENV{CI})
+ if (DEFINED ENV{TRAVIS})
+ set(BUILD_REPOSITORY $ENV{TRAVIS_REPO_SLUG})
+ set(BUILD_TAG $ENV{TRAVIS_TAG})
+ elseif(DEFINED ENV{APPVEYOR})
+ set(BUILD_REPOSITORY $ENV{APPVEYOR_REPO_NAME})
+ set(BUILD_TAG $ENV{APPVEYOR_REPO_TAG_NAME})
+ endif()
+endif()
add_custom_command(OUTPUT scm_rev.cpp
- COMMAND ${CMAKE_COMMAND} -DSRC_DIR="${CMAKE_SOURCE_DIR}" -P "${CMAKE_SOURCE_DIR}/CMakeModules/GenerateSCMRev.cmake"
+ COMMAND ${CMAKE_COMMAND}
+ -DSRC_DIR="${CMAKE_SOURCE_DIR}"
+ -DBUILD_REPOSITORY="${BUILD_REPOSITORY}"
+ -DBUILD_TAG="${BUILD_TAG}"
+ -P "${CMAKE_SOURCE_DIR}/CMakeModules/GenerateSCMRev.cmake"
DEPENDS
# WARNING! It was too much work to try and make a common location for this list,
# so if you need to change it, please update CMakeModules/GenerateSCMRev.cmake as well