summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorLiam <byteslice@airmail.cc>2023-04-03 01:02:04 +0200
committerLiam <byteslice@airmail.cc>2023-04-03 01:02:04 +0200
commita9623d5f550c8fc63f436a40f43bfbf539ac0853 (patch)
treeb6513dfee3b8410ab61d5e9ea799e757f049a1de /src/CMakeLists.txt
parentMerge pull request #10005 from liamwhite/kernel-atomics (diff)
downloadyuzu-a9623d5f550c8fc63f436a40f43bfbf539ac0853.tar
yuzu-a9623d5f550c8fc63f436a40f43bfbf539ac0853.tar.gz
yuzu-a9623d5f550c8fc63f436a40f43bfbf539ac0853.tar.bz2
yuzu-a9623d5f550c8fc63f436a40f43bfbf539ac0853.tar.lz
yuzu-a9623d5f550c8fc63f436a40f43bfbf539ac0853.tar.xz
yuzu-a9623d5f550c8fc63f436a40f43bfbf539ac0853.tar.zst
yuzu-a9623d5f550c8fc63f436a40f43bfbf539ac0853.zip
Diffstat (limited to '')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0eca8e90e..312a49f42 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -126,6 +126,17 @@ else()
add_compile_options("-stdlib=libc++")
endif()
+ # GCC bugs
+ if (CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL "12" AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ # These diagnostics would be great if they worked, but are just completely broken
+ # and produce bogus errors on external libraries like fmt.
+ add_compile_options(
+ -Wno-array-bounds
+ -Wno-stringop-overread
+ -Wno-stringop-overflow
+ )
+ endif()
+
# Set file offset size to 64 bits.
#
# On modern Unixes, this is typically already the case. The lone exception is