summaryrefslogtreecommitdiffstats
path: root/externals/CMakeLists.txt
diff options
context:
space:
mode:
authorMorph <39850852+Morph1984@users.noreply.github.com>2021-05-09 10:38:28 +0200
committerGitHub <noreply@github.com>2021-05-09 10:38:28 +0200
commitf2b76284ed5174c8c36b40f1bccaa6f66f9876c0 (patch)
tree021b5b619e60cdf2ab7b19be0fe53482281e054f /externals/CMakeLists.txt
parentUpdate SDL2 to SDL2-2.0.15-prerelease. (diff)
parentexternals: Use SDL2 statically (diff)
downloadyuzu-f2b76284ed5174c8c36b40f1bccaa6f66f9876c0.tar
yuzu-f2b76284ed5174c8c36b40f1bccaa6f66f9876c0.tar.gz
yuzu-f2b76284ed5174c8c36b40f1bccaa6f66f9876c0.tar.bz2
yuzu-f2b76284ed5174c8c36b40f1bccaa6f66f9876c0.tar.lz
yuzu-f2b76284ed5174c8c36b40f1bccaa6f66f9876c0.tar.xz
yuzu-f2b76284ed5174c8c36b40f1bccaa6f66f9876c0.tar.zst
yuzu-f2b76284ed5174c8c36b40f1bccaa6f66f9876c0.zip
Diffstat (limited to '')
-rw-r--r--externals/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/externals/CMakeLists.txt b/externals/CMakeLists.txt
index e044d9730..e280e53d7 100644
--- a/externals/CMakeLists.txt
+++ b/externals/CMakeLists.txt
@@ -47,7 +47,10 @@ target_include_directories(unicorn-headers INTERFACE ./unicorn/include)
# SDL2
if (NOT SDL2_FOUND AND ENABLE_SDL2)
+ set(SDL_STATIC ON)
+ set(SDL_SHARED OFF)
add_subdirectory(SDL EXCLUDE_FROM_ALL)
+ add_library(SDL2 ALIAS SDL2-static)
endif()
# SoundTouch