summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHarry Prevor <habs@sdf.org>2018-01-15 03:48:01 +0100
committershinyquagsire23 <mtinc2@gmail.com>2018-01-15 10:30:53 +0100
commitf2d55bb881902a808c18a7135ec2c257f463af95 (patch)
treeaac0f592deaaadec8dad5b46a6db0319d2292352 /CMakeLists.txt
parentMerge pull request #14 from ogniK5377/master (diff)
downloadyuzu-f2d55bb881902a808c18a7135ec2c257f463af95.tar
yuzu-f2d55bb881902a808c18a7135ec2c257f463af95.tar.gz
yuzu-f2d55bb881902a808c18a7135ec2c257f463af95.tar.bz2
yuzu-f2d55bb881902a808c18a7135ec2c257f463af95.tar.lz
yuzu-f2d55bb881902a808c18a7135ec2c257f463af95.tar.xz
yuzu-f2d55bb881902a808c18a7135ec2c257f463af95.tar.zst
yuzu-f2d55bb881902a808c18a7135ec2c257f463af95.zip
Diffstat (limited to '')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09fe9bcd3..2af11a4e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,6 +134,12 @@ else()
set(CMAKE_EXE_LINKER_FLAGS_RELEASE "/DEBUG /MANIFEST:NO /INCREMENTAL:NO /OPT:REF,ICF" CACHE STRING "" FORCE)
endif()
+# Fix GCC C++17 and Boost.ICL incompatibility (needed to build dynarmic)
+# See https://bugzilla.redhat.com/show_bug.cgi?id=1485641#c1
+if (CMAKE_COMPILER_IS_GNUCC)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-new-ttp-matching")
+endif()
+
# Set file offset size to 64 bits.
#
# On modern Unixes, this is typically already the case. The lone exception is